Not registered? Then you're not seeing all there is to see. Do you want to contribute? Register now by clicking HERE!
www.VNCommodore.com Support Site - Forums Page © 2005 - 2017
    Forums Page 

 
Main Menu

Start Page  
Forums  
Register  
Recipe Book  
Active Topics  
Active Polls  
Forum Search  
Online Auctions  
Online Classifieds  
FAQ  
Greeting Cards  
Guestbook  
Disclaimer  
Contact Us  
Links  
Username:

Password:

Save Password
Forgot your Password?

 
www.VNCommodore.com Support Forums
 All Forums
 General Area
 Technical Modifications
 Suspension symptom
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  
  Current Topic Rating: Total Rating: 0 | Join the Forum to Rate this Topic at: www.VNCommodore.com Support Forums  

Mechknight73
National Driver


robot-robot14

1001 Posts

Male

Posted - 05 Mar 2013 :  11:09:28 PM  Show Profile Send Mechknight73 a Private Message  Reply with Quote
 
This one was very weird before I found out what it was. Imagine driving down the road, and hearing a jingling sound, like a loose washer on an undersize bolt, every time you go over a bump the size of a cat's eye. Having asked my mechanic, he said "Sway bar link pins." Over time, stress on the will wear them loose, hence the strange jingling sound. Once replaced, you notice a huge improvement in the firmness of the front end.
Report to Moderator
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
www.VNCommodore.com Support Forums © 2005 - 2017 Go To Top Of Page  
This page shown in 0.06 seconds.   Snitz Forums 2000
Do not Click Here
   
 


Currently 401 user(s) online
 
Copyright © 2005 - 2017 by: Greening Computer Services